What are the technical requirements for using Omega WorkFlow Manager?

All you need is an internet connection. There’s nothing to install, and all you need is a modern web browser. Omega Workflow Manager is compatible with all popular browsers:

If you have to use IE7 or 8 – it works fine with them too but for best experience download the latest commercial version of the browser.
Internet Explorer
Google Chrome
Mozilla Firefox
Safari

Posted in: General FAQ's

Categories: